Results 1 to 3 of 3
  1. #1
    RC Enthusiast gandalfnz's Avatar
    Join Date
    Sep 2019
    Location
    New Zealand
    Posts
    28

    Idle speed to high even after richening both needles and decreasing idle gap to min

    Hi Guys

    I have a rustler that just idles way to high, and is overheating even at standstill.

    Its running the TRX 2.5

    I connected a long piece of tube and blew trough the carb, and cant hear any hissing or air getting out, its actually very very hard to blow? Is this normal? Would that mean that is not getting in enough fuel and there is a clog somewhere? Only when I do WOT I can then blow some air trough, but still very had to blow.

    Richening all needles and putting idle speed screw to absolute minimum does not make any change whatsoever?

    I mean, if none of the needles make any difference you would think the air leak is so big, I would hear the hissing sound when blowing trough he tube.

    When I close the filter housing with my finger, the car does shut down.
    I tried holding the fuel tank cap down, did not make any difference.
    Also, I cannot see any air bubbles going trough the fuel line.

    How can this be, never seen a nitro engine behaving like this before.

    I understand I am having too much air enter the system, but is it because of an air leak, or lack of fuel, I cannot seem to figure out. Seems like a lack of fuel to me, since adjusting the needles is not making any change.

    Please give me some advise.

    Thank you!
    Last edited by gandalfnz; 10-18-2019 at 07:24 PM.

  2. #2
    Traxxas Employee nixhex32's Avatar
    Join Date
    Mar 2001
    Location
    Ft Worth, tx
    Posts
    504
    What are the needles sitting at now? How many turns out from fully closed?
    Slash 4x4 lcg(heavily modded), Telluride(modded)gone, TCP, Monster Buggy, Latrax SST(heavily modded), Spartan, "My Summit" pic of that posted in the gallery........and some other things.

  3. #3
    RC Qualifier
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    298
    +1 on what are your settings at now.
    Also check your exhaust for any leaks. Side note; you had good tuning on your slash.
    What changed? New vehicle? Used engine?
    Last edited by grizzly03; 10-22-2019 at 12:56 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •