Results 1 to 2 of 2
  1. #1
    RC poster
    Join Date
    Jul 2015
    Posts
    3

    Traxxas M41 - not 100% throttle

    I just bought on ebay a used Traxxas DCB M41 in the Hawaii design. But sadly I am having a few issues.

    Upon the first trial run I noticed quickly that there was something wrong with the boat itself.
    When I accelerate the boat it seems that at a certain speed it wonīt speed up, instead it stays at the same speed or even less than that. As if I only go with half the speed. Doesnīt matter how much I trigger the throttle.

    I already tried to solve the problem by:
    - resetting the ESC manually to sport mode 1.
    Without any difference concerning the speed of the boat.

    As a second solution I:
    - installed the Traxxas Link bluetooth module from my UDR into the M41 remote to look up the current settings on the M41 on the Traxxas App and change them.
    - I thought that the M41 was on training mode - but there wasnīt any on.
    - The app itself installed some updates.
    - I reset the ESC to the factory settings.
    Still without any success.

    It honestly feels like the low voltage protection limits the power from the LiPo batteries to the motor.
    But I tried with four different 3S battery packs that I also got from the previous owner.

    If videos are needed please let me know.

    Right now I feel kinda helpless and I donīt have any ideas for other solutions.

  2. #2
    RC Racer
    Join Date
    Sep 2015
    Location
    Chesapeake, Va.
    Posts
    144
    Have you contact TRAXXAS support, they are pretty good about helping out.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •