Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Nov 2019
    Posts
    3

    TQI safety switch not working after upgrade

    I recently upgraded my slash 4x4 to a mamba monster x with a 2650kv motor. Kept the stoc Traxxas receiver and transmitter.

    Everything seems to be working but my Traxxas tqi transmitter safety switch no longer works. The throttle works whether the switch is engaged or not.

    Is this normal or am I missing something?

  2. #2
    RC Qualifier Panther6834's Avatar
    Join Date
    Jan 2019
    Location
    SF Bay Area
    Posts
    709
    Something I found out, when I attempted to install a Futaba Rx, but (temporarily) keeping the Traxxas ESC & motor, is that (with the exception of the servo) the Traxxas electronics are, essentially, a "system". The creatures/functions you mention are controlled by the Traxxas TX, but are still programmed into the Traxxas ESC.

    ~ More peace, love, laughter & kindness would make the world a MUCH better place
    ~ Love, laughter & kindness makes the world better

  3. #3
    RC poster
    Join Date
    Nov 2019
    Posts
    3
    Thanks. Figured as much

    Off topic but the mmx is defaulted at 5.5v. Do I need to or should I increase this to 6v since I believe the stock was running at 6 v?

  4. #4
    RC Qualifier Panther6834's Avatar
    Join Date
    Jan 2019
    Location
    SF Bay Area
    Posts
    709
    I've got a Mamba X in my Capra. When you bought your, there should have been something in the box related to getting a free USB Link. You'll need it (plus the downloadable software, and a microUSB) to program the ESC. You can plus it into a desktop/laptop...but, if you have a Windows tablet/2-in-1 (sick as a Microsoft Surface), that's what I'd recommend.

    ~ More peace, love, laughter & kindness would make the world a MUCH better place
    ~ Love, laughter & kindness makes the world better

  5. #5
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    13,559
    Quote Originally Posted by j0hnd0e View Post
    Thanks. Figured as much

    Off topic but the mmx is defaulted at 5.5v. Do I need to or should I increase this to 6v since I believe the stock was running at 6 v?
    If you want the same torque & speed output then yes. Test with a mutli-meter as I've found that after I program my Castle ESC it is always 0.1v lower than what I set it according to their program. To get 6.0v I had to set it to 6.1v; set to 7.3v to get 7.2v.
    The Super Derecho

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •