Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Dec 2019
    Posts
    1

    Exclamation Ez peak dual and lectron pro changing problems. PLEASE HELP!

    I bought my son a Stampede for christmas and it's the first hobby grade truck I've ever owned. Bought at Hobbytown and for extra batteries, I chose the lectron pro LiPos as the 2 store clerks and 3 other customers in at the time all agreed they were good batteries for cheap. I'm having problems charging them now and I'm lost as to what the issue is.

    I'm using the traxxas ez peak dual charger. Batteries are lectron pro 7.4v 7600mah and one 7.4v 5600mah.

    First, I wasnt aware the traxxas charger wouldnt automatically charge them. I found the many youtube videos on how to make it work. That's kind of a pain, but fine.

    So, I've got the batteries plugged in, along with the balance leads as well. Hold the start and charge rate buttons down to enter what was referred to as manual mode. Charger switches and reads it's a LiPo. I select balance mode as the YT videos suggested charging in and hold the start, and as soon as it tries to start charging it kicks to the error msg "abnormal power supply voltage detected". It does this with all 3 batteries. However, it WILL start charging if I select fast charge mode.

    What's going on here? I'm lost as to why it will charge one way and not the other. And honestly I'm lost as to why I should charge in balance mode as the YT videos said.

    Someone please help the new guy! Lol. Tyia.

  2. #2
    RC poster
    Join Date
    Feb 2020
    Posts
    2
    Any updates on this error? I get the same error on both live and legacy style batteries and have tried switching where plug the charger in at. The live batteries have only done it a couple of times and the legacy style finally only worked when in fast charge mode. I’ve only charged at 1C and lower and idk if this is a battery issue or charger issue. I just know is a pita. So any help will be appreciated.

  3. #3
    RC Competitor
    Join Date
    Dec 2019
    Location
    19004
    Posts
    83
    I'm not sure if we have exactly the same charger or not, but I have a Traxxas dual charger and do not have any LiPos with the ID plug on them. Never had a problem. Maybe a call to Traxxas is in order, the charger should work with more than just Traxxas's batteries.

  4. #4
    RC poster
    Join Date
    Dec 2018
    Posts
    12
    I have this exact same problem. It's only on my 2S lipos, balance charge and store mode works fine on my 3S packs.

    I sent mine in for replacement/repair. Traxxas sent me another one, same issue. They recommended NOT using their chargers on non-Traxxas batteries.

    Sent from my SM-G955U using Tapatalk

  5. #5
    RC Competitor
    Join Date
    Dec 2019
    Location
    19004
    Posts
    83
    Quote Originally Posted by Puddlejumpernva View Post
    I have this exact same problem. It's only on my 2S lipos, balance charge and store mode works fine on my 3S packs.

    I sent mine in for replacement/repair. Traxxas sent me another one, same issue. They recommended NOT using their chargers on non-Traxxas batteries.

    Sent from my SM-G955U using Tapatalk
    Funny, because I have two Traxxas brand chargers now and only one Traxxas brand battery, it's an old style 3S lipo with a balance plug, not ID.

    What I can absolutely report though, is the LEDs on the chargers like to die. On one charger (a single port one) the light for Lipo mode doesn't work. On the other, the Lipo mode light comes on slowly over time and one of the charging level indicator lights is dead.

    Occasionally, the dual charger has decided to not want to charge on the left side of the charger (and no, it's not because the left side is disabled through the "more power" switch), it seems if I start the right side first then the left, it's likely to fail, but if I start left first then right, its' fine.

    Not a hundred percent sold on Traxxas's chargers at this point, but they are working for me under heavy use and I got them used and cheap (so no real complaint in the end).

    If anyone has a favorite 3rd party charger I'd love to hear of it, not trying to hijack.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •