Results 1 to 3 of 3
  1. #1
    RC poster
    Join Date
    Jan 2020
    Posts
    1

    Using Traxxas Ez-peak charger and non-traxxas battery. Question about 'fast' charging

    So I bought a couple youme power 5200mAh 50C lipo batteries for my son. We have the EZ-Peak charger.

    I removed the front plate, and I plug in the battery (it uses the trx plug) and insert the white balance connection (I think that is what it's called).

    I do the mode in which it will recognize a non traxxas battery is connected. I originally was trying to charge it on balance mode, and each time I would start it...the 1 and 4 lights would blink, indicating something wasn't being read right.

    Today, I tried 'fast' charging mode...set it to 3a, and started it....and it's working. The battery was at the 1 light on charge, so I assume it was pretty much dead.... is this why the balance mode wasn't working? Or in the case of a non traxxas battery, is fast charging appropriate?

    Just trying to make heads/tails of this situation.

    Thanks!

  2. #2
    RC Champion FnFancy's Avatar
    Join Date
    May 2016
    Location
    Los Al California
    Posts
    1,681
    One should always balance charge lipo batteries! With that being said did you look at the chargers manual to see what the blinking 1 and 4 light means?

    it's alright son, I'll fix it
    Its alright son I'll fix it when you break it

  3. #3
    RC Enthusiast
    Join Date
    Dec 2019
    Posts
    24
    I do not know your battery enough to say for certain, but most Lipos are safely charged at 1 or even 2 c, so anywhere from 5-10a.

    I balance charge most of mine at 6a, no fires so far. I have the dual version of your charger.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •