Results 1 to 3 of 3
  1. #1
    RC poster
    Join Date
    Jan 2020
    Posts
    1

    Exclamation Servo/Receiver problems help! (TRX4)

    Recently I ran my TRX4 through quite deep and very cold water, it was doing well for about 10 minutes until the steering servo froze when I was making right turn in the water, when I took it out of the water I restarted it and the servo returned to the center position, when I turned the wheel on the transmitter I wasn't getting any response from the servo. I tried turning the wheels by hand when it was on to see if it resisted like it was supposed to and it did, the servo seemed to be working but it didn't respond. a few minutes after I lost throttle. when I got back home I opened the waterproof box to check the receiver, there was a bit of water inside so I clean it out and left it to dry for a few days, then I plugged everything back together to find everything worked except the steering. so I unplugged the steering and switched it with channel 4 where the Gear Shifting mini servo is supposed to be, the servo worked in that channel but on the High and Low switch, so I plugged in the gear shifting servo to the steering channel (Channel 1) and I was able to control the mini servo with the wheel on the transmitter.

    I can't figure out if it is a Servo problem or a Receiver problem because the servo doesn't work in its channel, but in another channel, it works fine, And if I plug in a mini servo meant for shifting gears to the steering channel it works fine,

    Please help! Thanks

  2. #2
    RC Turnbuckle Jr. Greatscott's Avatar
    Join Date
    Mar 2004
    Location
    N. Idaho... Da Sticks!
    Posts
    7,946
    My guess would be that your RX is at fault. Recommend putting the RX in rice for a day or two and trying it again. If it still fails after that, replace the RX.

    When you seal back up the receiver box, make sure the seals are seated where they are supposed to be. Also, put a light coat of silicone lubricant on all of the seals.
    Submarine Qualified, Chief Inducted, Navy Retired

  3. #3
    RC Qualifier TITANIUM94010's Avatar
    Join Date
    Sep 2019
    Location
    San Francisco CA
    Posts
    310
    You may have fried or short-circuited the servo lane on your receiver. I stressed my motor too much my stopping it from spinning at full throttle, sparks came out and the motor lane on the receiver stopped working. I think you need a new receiver.
    Jumping: maneuver and pray it won't break.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •