Results 1 to 9 of 9

Thread: TSM Question

  1. #1
    RC Qualifier
    Join Date
    Dec 2016
    Location
    Burleson, Texas
    Posts
    255

    TSM Question

    I finally got my Castle motor back from replacement (over 3 month wait, ) but it's here!!
    My new combo is Monster X 1/8 Brushless Combo w/1512 Sensored Motor (2650kV) and the only issue I have is when I set the TSM to anything above 0 the steering seems to try and correct itself. Doesn't matter if I just turn it on or if I've been driving it for a bit - the steering servo will may some noise and the steering slowly turns. Then resets to straight.
    I did some searching but I couldn't fond anything using my terminology.

    Any thoughts?
    Scott
    Slash 2wd
    Slash Ultimate 4wd
    Stampede 4wd

  2. #2
    RC Turnbuckle Jr. El Sob's Avatar
    Join Date
    Feb 2010
    Location
    Indianapolis
    Posts
    14,273
    It's hard to comprehend exactly what you are dealing with. Could you please upload a video so we can see firsthand what you are describing?
    Member of the 10,000 + posts club! Here to help!

  3. #3
    RC Qualifier
    Join Date
    Dec 2016
    Location
    Burleson, Texas
    Posts
    255
    I'll try and get one tonight. If not it will be Sunday before I am near the truck again.
    Scott
    Slash 2wd
    Slash Ultimate 4wd
    Stampede 4wd

  4. #4
    RC Qualifier
    Join Date
    Dec 2016
    Location
    Burleson, Texas
    Posts
    255
    Here we go, hopefully it works..

    Steering works fine with the VXL system but when I switched to the Mamba Monster X and 2650kV motor it started acting up. Any time I would turn the multi-function knob the steering will move on its own. As soon as I turn it off the steering goes back to center. The higher I turn the multi-function knob the faster it moves. Steering trim setting has no effect.
    I've use the bid function a couple of times but after that I am lost. It is more of an annoyance than anything because I haven't noticed it messing with the steering while I am driving but it would be nice to get it sorted.



    Thanks!
    Last edited by Scott91370; 01-17-2020 at 07:06 PM.
    Scott
    Slash 2wd
    Slash Ultimate 4wd
    Stampede 4wd

  5. #5
    RC Qualifier
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    589
    This might be a long shot, but maybe try re-calibrating your TX/RX and then re-calibrate your esc.

  6. #6
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    13,703
    Tsm ?
    The Super Derecho

  7. #7
    RC Qualifier
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    589
    Quote Originally Posted by Double G View Post
    Tsm ?
    Should've worded my post better. Try doing a factory reset on the controller in case some setting got changed, then check steering servo end points are ok. After that you would need to re-calibrate the ESC. Should only take a few minutes to perform these resets. If TSM worked before the Castle Creations install and not work after, something has changed. TSM should work the same way before and after install of different ESC and motor.
    Did you install a different servo? Have the BEC voltage set different than 6v?

    Traxxas support video to reset transmitter: youtubeTraxxasSupport
    Castle Creations support video to calibrate mamba x Esc: youtubeCastleCreations

  8. #8
    RC Qualifier
    Join Date
    Dec 2016
    Location
    Burleson, Texas
    Posts
    255
    The servo is the same one with both systems.

    I'll do the complete reset, check the BEC voltage and report back. It will probably be late tomorrow I have to head out of town for the day.
    Scott
    Slash 2wd
    Slash Ultimate 4wd
    Stampede 4wd

  9. #9
    RC Turnbuckle Jr.
    Join Date
    Feb 2002
    Posts
    9,407
    you have an improper setup from the esc to receiver

    you need to address that. make sure the trims are @ 0, or it will not work properly. esc needs to be cailibrated

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •