Results 1 to 10 of 10

Thread: Help please?

  1. #1
    RC poster
    Join Date
    Sep 2010
    Posts
    14

    Help please?

    Hey all, looking for a bit of help here. Truck has a weird hesitation, wondering if it's the batteries or ESC or maybe something else. Under full throttle or when I "punch it" it always does this stutter, it hasn't always done this since new though. If I ease into it, it will go just fine and hit max speed, etc.

    https://photos.app.goo.gl/9K8Xwki591XF8PGF6

    Hopefully the video link works.

  2. #2
    RC Champion
    Join Date
    Apr 2018
    Posts
    1,043
    Have you tried to recalibrate the esc? It may need to be done. Also are you running the latest software version for the esc? And also, make sure you have good batteries. It sure what you are using. Maybe post some more info. All the info you can think of helps us to help you. Hopefully you get it resolved.

  3. #3
    RC poster
    Join Date
    Sep 2010
    Posts
    14
    I'm using traxxas 4s 6700's. I have been reading about calibrating the esc and updating it so I will do that tomorrow. Im going to buy new batteries if that was the case but took them to my LHS to be tested and the readings were all good.

    Do I need anything special to update the ESC?

  4. #4

  5. #5
    RC poster
    Join Date
    Sep 2010
    Posts
    14
    So before I reset the esc I'm going to charge the batteries. Here is the readings off of the ez peak charger. Each cell is reading 4volts so first battery seems good.

    https://photos.app.goo.gl/Z62hhqUoP1t1sEKx8

  6. #6
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,265
    Also check motor connections. My Erevo stuttered bad when one motor connection came apart. Also check and make sure driveline isn't binding.

  7. #7
    RC poster
    Join Date
    Sep 2010
    Posts
    14
    Just calibrated the ESC, still having the issue. Will be picking up the bluetooth module from my LHS tonight and will see if the update fixes it.

  8. #8
    RC Champion
    Join Date
    Apr 2018
    Posts
    1,043
    If all other stuff you have done isnít helping, as said, check the motor wires for solid connection to esc. If that doesnít help, I would think that the only option left is to update the ESC. If in the end this doesnít solve said issue, I would give Traxxas support a call and see if they might be of some help. Sucks that you are having this issue. Hopefully you get it worked out.

  9. #9
    RC poster
    Join Date
    Sep 2010
    Posts
    14
    So called traxxas ended up recalibrating the remote and ESC again. It's almost 100% gone. I'll still end up getting that module and updating to see if that helps also. I did check all of the connections and I am 100%

  10. #10
    RC Champion
    Join Date
    Apr 2018
    Posts
    1,043
    Well at least you made some headway about the issue. I will say that a sensor less brushless motor will cog a little on take off. Itís normal and youíll experience it more as you gear up. Hopefully the update will take whatís left of the little bit of lurching and get rid of it. You can also try gearing down just a little. But as I said, with any sensor less brushless motor youíll have a little cog on take off.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •