Results 1 to 5 of 5

Thread: Nitro Revo 3.3

  1. #1
    RC poster
    Join Date
    Feb 2020
    Posts
    2

    Nitro Revo 3.3

    I have a newer revo 3.3 and I'm having trouble with my servos. My battery pack is new and my reverse servo is new. I will charge it completely and both the throttle and steering will work for a short time then they both quit working. I have no clue what is going on and some help or advice would be greatly appreciated.

  2. #2
    RC Qualifier Rocketzx1's Avatar
    Join Date
    Oct 2018
    Location
    Tennessee
    Posts
    391
    Around how long is a short time? Like 10-15 mins? Are you sure you have a high enough mah battery, or that itís not a bad battery? Do you have another battery you could try?


    Sent from my iPhone using Tapatalk

  3. #3
    RC poster
    Join Date
    Feb 2020
    Posts
    2
    It'll stay on as long as I don't touch the throttle on the remote. Maybe a few minutes. When I touch the throttle on the remote it switches into reverse and all servos quit working. Yes I have tried 3 different batteries with the same outcome. One being brand new.

  4. #4
    RC Qualifier
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    655
    What happens when you unplug the reverse servo? Does throttle and steering work normal?

  5. #5
    RC poster
    Join Date
    Jan 2018
    Posts
    11
    If you have the Traxxas TQi 2.4GHz transmitter and TQi 2.4GHz 5-channel micro receiver with TSM it's not all brands of servos that work well with that combination and can give you a glitch. I only use Traxxas servos with Traxxas radio system.
    Also if you are using other than Traxxas radio and/or servo double check the servo plug is in the right way.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •