Results 1 to 8 of 8

Thread: Esc issue

  1. #1
    RC poster
    Join Date
    Jan 2020
    Posts
    15

    Esc issue

    So I am having some trouble with the ESC in my xmaxx.

    After running the truck for about 5 minutes, it all of a sudden lost all power. No steering, no throttle, nothing.

    Took the body off, no lights on.

    Hit the power button on the esc - truck powers on and then immediately off. No lights.

    If I hold the power button the truck powers on and I have steering but no throttle. If I release the power button everything shuts off.

    Any idea what is causing this? Personally I think the ESC is toast, but I am hoping its something less severe.

    I am running 9400 mah SMC 50C lipos. When the issue happened I put them on my charger, and the readout said all cells were just under 4.1V.

    Thoughts?

  2. #2
    RC Turnbuckle Jr.
    Join Date
    Oct 2016
    Posts
    4,555
    Esc button stuck?, RX get wet?


    Sent from my iPhone using Tapatalk

  3. #3
    RC Qualifier Acidic01's Avatar
    Join Date
    Jul 2018
    Posts
    551
    Check your batter connections and wires as well.

    I second could be a stuck esc button.

    Sent from my Pixel 3 XL using Tapatalk

  4. #4
    RC poster
    Join Date
    Jan 2020
    Posts
    15
    No dice. Checked battery connections and they are fine. Checked ESC button and it is not stuck. All connections seem to be solid.

    Transmitted did not get wet (though I was running the truck in some light snow when this happened.

  5. #5
    RC Qualifier Acidic01's Avatar
    Join Date
    Jul 2018
    Posts
    551
    Quote Originally Posted by shonuff2653 View Post
    No dice. Checked battery connections and they are fine. Checked ESC button and it is not stuck. All connections seem to be solid.

    Transmitted did not get wet (though I was running the truck in some light snow when this happened.
    If a new purchase I'd give Traxxas a call and have them help you trouble shoot or get you a support ticket to send esc in for warranty replacement.



    Sent from my Pixel 3 XL using Tapatalk

  6. #6
    RC Champion nickruger's Avatar
    Join Date
    Jun 2017
    Location
    Ohio
    Posts
    1,354
    Do you know what you're temps were at the time of the incident? Reason I'm asking is because when you run in snow your temps can sky rocket really quickly due to the exponential increase in wheel spin. Your truck can be running flat out alot even though to the eye it doesn't seem to be moving that fast from all the wheel spin. I have had traxxas ESCs jump past thermal protection in this particular situation, that's why I'm wondering.

    Sent from my SM-N960U using Tapatalk

  7. #7
    RC poster
    Join Date
    Jan 2020
    Posts
    15
    No idea what the temps were. I did have a few speed runs but nothing super long. I was mainly running small jumps across some snow drifts.

    Unfortunately this is not a new purchase. No hope for an esc replacement at this stage I think.

  8. #8
    RC Racer
    Join Date
    Feb 2020
    Location
    Canary Islands, Tenerife, Spain.
    Posts
    146
    Quote Originally Posted by shonuff2653 View Post
    No idea what the temps were. I did have a few speed runs but nothing super long. I was mainly running small jumps across some snow drifts.

    Unfortunately this is not a new purchase. No hope for an esc replacement at this stage I think.
    Maybe you can buy a Hobbywing Max6 ESC, it's a common aftermarket replace for stock ESC, or of course, can purchase an original one, is a very good equipment.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •