Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Mar 2020
    Posts
    1

    Trx-4 Land Rover wonít move

    Hi,

    I’ve recently bought the trx4 Land Rover, I’ve used it a few times but this weekend just gone I decided to take on to the beach and so I was using it for around an hour with no problem both on the sand and in some shallow water, on way back to the car it stopped which initially I thought it had run out of battery and just put it in the back of the car and set off home. The next day I charged it and switched it on but it wouldn’t drive forwards or backwards.... only the steering would work. I’ve tried to calibrate but it won’t calibrate.

    I’m just wandering if anyone can point me in the right direction??

    Many thanks, Peter

  2. #2
    RC Racer
    Join Date
    Aug 2017
    Posts
    211
    I am not sure but maybe carefully inspect the wire from esc to receiver which is your throttle...
    It's obviously receiving power if steering is working.

    I have never blown an esc or motor (knock on wood) so I am not sure but I am curious

    Sent from my SM-G965W using Tapatalk

  3. #3
    RC Enthusiast
    Join Date
    Feb 2020
    Location
    Oregon
    Posts
    30
    Check to make sure that the spades in your ID connectors are in the ID connector fully. I had mine not seated all the way, which would allow for the steering to still work but no forward or reverse. I had to push the spades in the ID connector for the ESC in with a flat head screwdriver to seat properly. This fixed my issue.
    Nate

    Rustler 4x4, TRX-4 Traxx

  4. #4
    RC poster
    Join Date
    Jan 2020
    Posts
    12
    Quote Originally Posted by Pjbmell77 View Post
    Hi,

    Iíve recently bought the trx4 Land Rover, Iíve used it a few times but this weekend just gone I decided to take on to the beach and so I was using it for around an hour with no problem both on the sand and in some shallow water, on way back to the car it stopped which initially I thought it had run out of battery and just put it in the back of the car and set off home. The next day I charged it and switched it on but it wouldnít drive forwards or backwards.... only the steering would work. Iíve tried to calibrate but it wonít calibrate.

    Iím just wandering if anyone can point me in the right direction??

    Many thanks, Peter
    I, only a week ago or so, had a similar issue with my TRX4 Traxx. Only difference I see is my steering servo was not responsive to radio inputs either. My truck was completely dead and unresponsive, and in fact I could not turn it off at the ESC either. I sent the ESC and the receiver box into Traxxas, my truck was only a little over a month old and had not been driven hard to that point. Found out the ESC had gone bad, and Traxxas promptly replaced it.

  5. #5
    RC Champion FnFancy's Avatar
    Join Date
    May 2016
    Location
    Los Al California
    Posts
    1,808
    Is it the stock brushed motor? Salt water and sand, combined with sitting for a day could have corroded the brushes to the point of either rusted tight or not making contact.

    it's alright son, I'll fix it
    Its alright son I'll fix it when you break it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •