Results 1 to 8 of 8
  1. #1
    RC poster
    Join Date
    Apr 2020
    Posts
    12

    Erevo hesitating then after a bit comes out of it

    So I just bought a used machine and when you go to take off it hesitates hesitates hesitates hesitates then it will go a little bit and then all of a sudden all the powers there and starts ripping go through a field it's good I stop it starts hesitating again and reverse doesn't work and then I keep trying to go in reverse and then it will go in reverse after four or five tries and it just goes slow and try to go forward it hesitates again over and over I'm done all of a sudden it just comes out of it and I can use it for a bit please help I've had bad luck so far with two I've bought and just want to play with everyone else's

    Sent from my ONEPLUS A5010 using Tapatalk

  2. #2
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,273
    Check to make sure all three motor wire connections are tight.

  3. #3
    RC poster
    Join Date
    Apr 2020
    Posts
    12
    Ok

    Sent from my ONEPLUS A5010 using Tapatalk

  4. #4
    RC poster
    Join Date
    Apr 2020
    Posts
    12
    They all were

    Sent from my ONEPLUS A5010 using Tapatalk

  5. #5
    RC poster
    Join Date
    Apr 2020
    Posts
    12
    Can I use any ESC and motor combo or with a 2 or 3 s battery or does it matter I have a few cars and just getting into now that I have a home with land and have had bad luck bought a yeti and with in two minutes of use it's just jerking and doesn't move then I bought the erevo and it hesitates no reverse then after a bit has full power then back to hesitating and no reverse

    Sent from my ONEPLUS A5010 using Tapatalk

  6. #6
    RC Champion FnFancy's Avatar
    Join Date
    May 2016
    Location
    Los Al California
    Posts
    1,831
    I think a bit more information, as well as punctuation, is needed. What esc, motor and controller are in it? Does it require full throttle to get going? How long are you waiting in neutral before trying reverse?

    it's alright son, I'll fix it
    Its alright son I'll fix it when you break it

  7. #7
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,273
    What are your batteries? Are they good? If these batteries are used in another vehicle and that vehicle acts the same way, I would say something is wrong with the batteries.

  8. #8
    RC poster
    Join Date
    Apr 2020
    Posts
    12
    There the batteries that came with it I'm waiting for the plugs so I can interchange them but covid-19 is screwing everything up

    Sent from my ONEPLUS A5010 using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •