Results 1 to 7 of 7
  1. #1
    RC poster
    Join Date
    Apr 2020
    Posts
    3

    Vlx 6s isn't powering on

    Hello everyone I'm new to the hobby just got my m41 and I ran it 3 times perfectly, however today I went out to run it and ecs doesn't power on. Batteries are fully charged. What can be the issue boat is brand new.

  2. #2
    RC Champion
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    1,113
    Check to see if you have a loose solder connection on any of the tabs from the esc to the batt's and make sure the plug in the rx didn't get jostled loose, if all of that looks good contact Traxxas Support.

  3. #3
    RC poster
    Join Date
    Apr 2020
    Posts
    3
    Sorry I'm new to this what's the rx. The solder on the esc look good.

  4. #4
    RC Champion
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    1,113
    It's the receiver, where the esc wire and the servo plugs into that little black box.

  5. #5
    RC poster
    Join Date
    Apr 2020
    Posts
    3
    Ok so I checked rx and everything looks good. I did notice that when I go connect my 2nd battery it makes like a popping noise and saw some sparks

  6. #6
    RC Champion
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    1,113
    Quote Originally Posted by Miami_e36_jr View Post
    Ok so I checked rx and everything looks good. I did notice that when I go connect my 2nd battery it makes like a popping noise and saw some sparks
    The arcing is normal when plugging in the second battery on most rc's 6s and up, if you still don't have any lights come on the esc when plugging it in contact the hobby shop or the place you bought it and see if they have a second esc you can try.
    There is a row of 3 black caps, check and see if any are deformed or popped at the top, they have little indentation lines that will let go under extreme heat and you have to replace the esc.
    If you only ran it a few times it should be under warranty so contact Traxxas support and they will help you out.

  7. #7
    RC poster
    Join Date
    Jul 2020
    Posts
    1
    Hi Miami, did you get the VXL-6S issue sorted?

    Similar issue with my M41, arrived, checked, lubricated everything and took it out on the lake only for it to stop �� and I had to recover it, batteries checked all ok, plugged them back in and nothing from ESC.

    In consultation with supplier to decide whether to return or replace.....not happy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •