Results 1 to 15 of 15

Thread: throttle isue

  1. #1
    RC poster
    Join Date
    Apr 2020
    Posts
    9

    throttle isue

    when use full throttle it stalls on low and mid throttle it runs fine on my first battery there was no problem what could be wrong esc light is green ive calibrated the esc also

  2. #2
    RC Qualifier
    Join Date
    Mar 2015
    Posts
    272
    I think it's a bit hard for us to answer your question with the info we've been given.

    Can you be a bit more descriptive of what's going on? When you say "stall" do you mean stop completely or slow down or something else?

    Is this happening while using a battery you just charged, or a less-than-full battery?

    Are you going full throttle from dead stop, or are you already rolling?

    All in all it sounds like this is possibly an ESC warranty issue, but with a bit more info maybe we can help you out.

  3. #3
    RC Qualifier RCWilly's Avatar
    Join Date
    Feb 2019
    Location
    California Bay Area
    Posts
    808
    @ rdg72, the ESC is supposed to be green. It is normal for the motor to stall a bit (it does at least on mines) at low speeds, since it is an unsensored motor. How much is yours stalling?

  4. #4
    RC poster
    Join Date
    Apr 2020
    Posts
    9
    i use a full battery when its already rolling and i use fullthrottle it stals not completely it stutters more

  5. #5
    RC Qualifier RCWilly's Avatar
    Join Date
    Feb 2019
    Location
    California Bay Area
    Posts
    808
    Are you sure it's not the sound that the motor makes? Try pushing the car to make the wheels spin and see if it makes the same sound.

  6. #6
    RC poster
    Join Date
    Apr 2020
    Posts
    9
    its a little hard to explain in english becouse im dutch but when i use throttle it starts running then it stops a little then it drives normally

  7. #7
    RC Qualifier RCWilly's Avatar
    Join Date
    Feb 2019
    Location
    California Bay Area
    Posts
    808
    The motor does get stuck for me too at low speeds. Does yours do it at high speeds?

  8. #8
    RC poster
    Join Date
    Apr 2020
    Posts
    9
    yes it does i think

  9. #9
    RC Qualifier
    Join Date
    Mar 2015
    Posts
    272
    The motor should stutter when using low throttle input from a dead stop. That's just a problem with non-sensored brushless motors like the UDR has. Low speed control sucks unless you install a sensored system.

    But the stuttering shouldn't happen when the truck is already rolling, and it certainly shouldn't happen at higher throttle inputs.

    It sounds like your problem warrants a call to Traxxas. If you've only put one battery through the truck, then you've likely got a warranty issue here.

    I hope you get it solved. Let us know what happens.

  10. #10
    RC poster
    Join Date
    Apr 2020
    Posts
    9
    i send it to my local hobby shop im waiting for the info

  11. #11
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,271
    Sounds like a possible battery issue. Not able to supply the amperage required when accelerating.
    Does it stall less when accelerating slowly?
    Does it stall more when trying to accelerate fast?

  12. #12
    RC poster
    Join Date
    Apr 2020
    Posts
    9
    it stalls more at fast acceleration the batterys are ok i use them in my rustler and maxx also
    Last edited by rdg72; 04-24-2020 at 03:00 PM.

  13. #13
    RC Qualifier RCWilly's Avatar
    Join Date
    Feb 2019
    Location
    California Bay Area
    Posts
    808
    Hmm, interesting. Have you tried contacting Traxxas?

  14. #14
    RC Racer
    Join Date
    Jun 2018
    Posts
    111

    stall problem

    Quote Originally Posted by rdg72 View Post
    it stalls more at fast acceleration the batterys are ok i use them in my rustler and maxx also
    Have you tried resetting esc......

  15. #15
    RC poster
    Join Date
    Apr 2020
    Posts
    9
    i just got it back from the shop it was a motor problem due to a broken driveshaft got a new motor from traxxas it was waranty thanks traxxasfor the great service and i upgraded the rear diff i will drive it at the weekend see if its running smooth againthanks for the input everybody

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •