Results 1 to 13 of 13
  1. #1
    RC Qualifier TITANIUM94010's Avatar
    Join Date
    Sep 2019
    Location
    San Francisco CA
    Posts
    324

    Anyone run their body without clips?

    Does anybody else run their TRX4/TRX6 without body clips with the post?

    I don't use clips on all of my cars, and my TRX6 has a half magnetic mounting system (rear magnetic front posts)

    Was just wondering.
    Jumping: maneuver and pray it won't break.

  2. #2
    RC Enthusiast
    Join Date
    May 2015
    Posts
    21
    I use 1/16 clips, with the little rubber grab tabs added.

    I don't want the body coming off if (when) it rolls over on a side hill...

  3. #3
    RC Turnbuckle Jr. Greatscott's Avatar
    Join Date
    Mar 2004
    Location
    N. Idaho... Da Sticks!
    Posts
    7,961
    Quote Originally Posted by Gazoombah View Post
    I use 1/16 clips, with the little rubber grab tabs added.

    I don't want the body coming off if (when) it rolls over on a side hill...
    I have tried magnetic body post before, never had any success with them, the body always comes off in a roll over. Guess I just need to be a better driver.
    Submarine Qualified, Chief Inducted, Navy Retired

  4. #4
    RC poster
    Join Date
    May 2020
    Location
    AL
    Posts
    2
    Can anyone tell me why I am getting paint rub off near the body clip area with the washer provided? Is there anyway to prevent this? I also have a Bigfoot with paint rubbing off on the bed mount support and have yet to find a way to prevent it.

  5. #5
    RC Turnbuckle Jr. Greatscott's Avatar
    Join Date
    Mar 2004
    Location
    N. Idaho... Da Sticks!
    Posts
    7,961
    I do actually have two builds that do not have body clips, both are hard-bodies. On one I use magnetic mounts, they work ok, but, the body will still come off if it gets a shock.

    http://www.rccrawler.com/forum/non-c...-blizzard.html

    The other build is my Element C1 rig with a hard body. I am using a hybrid mounting system for this build, using the mounting system it comes with body in the front and one I designed and printed in the back. Hopefully these will give you some ideas.

    http://www.rccrawler.com/forum/eleme...ement-kit.html
    Submarine Qualified, Chief Inducted, Navy Retired

  6. #6
    RC Qualifier
    Join Date
    Feb 2020
    Location
    Canary Islands, Tenerife, Spain.
    Posts
    657
    I prefer the clips.

  7. #7
    RC Qualifier
    Join Date
    May 2014
    Posts
    978
    I guess I'm old I just use clips. I keep meaning to try some magnets on my boys truck. My friend has magnets on some of his trucks but he uses earth magnets on the body and swears by them.

  8. #8
    RC Racer
    Join Date
    Oct 2018
    Posts
    149
    I put the rare earth ring magnets on the hood of my son's wraith. I love them. They are big, bigger and stronger then i need. Haven't had it fall off, even with some big tumbles. It is only just the hood though. I ripped the paint off before the magnets came apart though. Reglued it and alls been well since. Can toss the hood at it while its on the ground and it'll install itself.
    I can see the big hardbodies falling off in a tumble, but using either magnets or velcro gives a more realistic look over the usual posts and clips.

    Sent from my SM-G970U using Tapatalk

  9. #9
    RC Qualifier TITANIUM94010's Avatar
    Join Date
    Sep 2019
    Location
    San Francisco CA
    Posts
    324
    I’m fine with using clips on my fastest rigs because
    Their the only way to go, but they’re a pain to put on and take off all the time.


    Sent from my iPhone using Tapatalk
    Jumping: maneuver and pray it won't break.

  10. #10
    RC Racer
    Join Date
    May 2016
    Posts
    117
    On my slash buggy build i use velcro. I left the body posts on for alignment but then put velcro on the nerf bars and the inside of the body. It works perfect. Never comes off even when crashing at highspeeds or landing wrong off a big jump. No more clips for me.

  11. #11
    RC Enthusiast
    Join Date
    May 2020
    Posts
    41
    Quote Originally Posted by TITANIUM94010 View Post
    Does anybody else run their TRX4/TRX6 without body clips with the post?

    I don't use clips on all of my cars, and my TRX6 has a half magnetic mounting system (rear magnetic front posts)

    Was just wondering.
    I did the trx 6 with magnets it works wonder but good magnets cost about 20 bucks


    Sent from my iPhone using Tapatalk

  12. #12
    RC Enthusiast
    Join Date
    May 2020
    Posts
    41
    Quote Originally Posted by michaelbackwood View Post
    I did the trx 6 with magnets it works wonder but good magnets cost about 20 bucks


    Sent from my iPhone using Tapatalk



    Sent from my iPhone using Tapatalk

  13. #13
    RC Qualifier
    Join Date
    Feb 2020
    Location
    Canary Islands, Tenerife, Spain.
    Posts
    657
    The best magnets for this are neodimium, strong and small.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •