Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Mar 2020
    Posts
    10

    Is my servo shot?

    So I replaced gears for 2nd time. Worked for a few then now itís like servo not even getting power to it. No noise at all. Itís only 5 months old but driven hard by my son. Just seeing if there is maybe a fuse or something or if replacing entire servo is needed. Thanks!

  2. #2
    RC Qualifier Panther6834's Avatar
    Join Date
    Jan 2019
    Location
    SF Bay Area
    Posts
    963
    Just curious, but, what brand is it...the stock Traxxas servo, or aftermarket? I know, with my Rustler, the very first upgrade I did was to replace the Traxxas servo with a Hitec servo.

    ~ More peace, love, laughter & kindness would make the world a MUCH better place
    ~ Love, laughter & kindness makes the world better

  3. #3
    RC poster
    Join Date
    Mar 2020
    Posts
    10
    It’s the stock 2075

  4. #4
    RC Qualifier Panther6834's Avatar
    Join Date
    Jan 2019
    Location
    SF Bay Area
    Posts
    963
    Quote Originally Posted by Brotherskeeper View Post
    It’s the stock 2075
    In that case, can don't water your money...just get something better...something not 'Traxxas'. Overall, their vehicles are outstanding, and the other electronics are mostly good, but I don't care for the servos.

    ~ More peace, love, laughter & kindness would make the world a MUCH better place
    Last edited by cooleocool; 05-25-2020 at 01:41 AM. Reason: Be mindful about how you reference Traxxas products, this is a Traxxas forum afterall.
    ~ Love, laughter & kindness makes the world better

  5. #5
    RC poster
    Join Date
    Mar 2020
    Posts
    10
    Yep servo was shot. Couldn’t get anything upgraded today as that’s all they had and we needed it today. Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •