Results 1 to 5 of 5
  1. #1
    RC Enthusiast
    Join Date
    Apr 2020
    Posts
    29

    E revo still locked up

    Hey guys so when there are no diffs connected to
    my E Revo the transmission moves fine when there is a diff connected it will move but only when there is no weight on it what is causing this?


    Sent from my iPhone using Tapatalk

  2. #2
    RC Competitor
    Join Date
    Nov 2019
    Posts
    67
    I don't completely follow what diagnostic steps you have taken. I read your original post too.

    It sounds like you removed both drive shafts (front and back) and the chassis would roll freely, but if you connect the rear drive shaft to the center diff and transmission it locks up?

    Sent from my SM-G950U1 using Tapatalk

  3. #3
    RC Champion Acidic01's Avatar
    Join Date
    Jul 2018
    Posts
    1,048
    Perhaps post a vid of issue?

    Sent from my Pixel 3 XL using Tapatalk

  4. #4
    RC Enthusiast
    Join Date
    Apr 2020
    Posts
    29
    Problem solved one of the pins in the gearbox was loose causing the gear to grind against each other


    Sent from my iPhone using Tapatalk

  5. #5
    RC Champion Acidic01's Avatar
    Join Date
    Jul 2018
    Posts
    1,048
    Quote Originally Posted by Smashem77 View Post
    Problem solved one of the pins in the gearbox was loose causing the gear to grind against each other


    Sent from my iPhone using Tapatalk
    Glad you found the issue.

    Sent from my Pixel 3 XL using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •