Results 1 to 6 of 6
  1. #1
    RC poster
    Join Date
    May 2020
    Posts
    8

    lipo charging problem

    Ok so I went and got a pair of 2s 5200mAh 50c batteries from amazon and also picked up a Traxxas EZ-Peak plus charger. Now on my 3rd time charging them I'm getting error codes and they won't charge. I'm getting the 1a and 4a lights flashing. Does anyone know what is wrong? The batteries are only 2 weeks old.

  2. #2
    RC Champion
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    1,101
    Do you have a lipo checker or can you check the volts, maybe you ran them to low. Not accusing just asking it happens sometimes.

  3. #3
    RC poster
    Join Date
    May 2020
    Posts
    8
    I don't have a lipo checker. I have to look for a volt meter to check the volts(what should it be?). I don't think I ran the to low, I had the low-voltage detection on.

  4. #4
    RC Champion
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    1,101
    Quote Originally Posted by nootch View Post
    I don't have a lipo checker. I have to look for a volt meter to check the volts(what should it be?). I don't think I ran the to low, I had the low-voltage detection on.
    I have never gone below 3.5v per cell, I use the BT Module with the app and set it at 3.7 per cell because 1 side always drops a little more then the other so I'm just trying to stay above 3.5v.

    I have heard of people going as low as 3.2v and it being ok but check it with the volt meter and if you have a friend with a different charger to try it on or check your LHS and get them to check just to be safe.

  5. #5
    RC poster
    Join Date
    May 2020
    Posts
    8
    Well I ended up returning the packs for a refund. I had also ordered a 2s 55c 7000mAh pack and when I got that one(the same day I sent the other 2 back) I put on the charger and the same thing, the pack wouldn't charge. I tried to check the voltage and it was so low the volt meter couldn't even register it. So that is the last time I buy HRB packs.

  6. #6
    RC Champion
    Join Date
    Dec 2017
    Location
    Van. Island British Columbia
    Posts
    1,101
    Quote Originally Posted by nootch View Post
    Well I ended up returning the packs for a refund. I had also ordered a 2s 55c 7000mAh pack and when I got that one(the same day I sent the other 2 back) I put on the charger and the same thing, the pack wouldn't charge. I tried to check the voltage and it was so low the volt meter couldn't even register it. So that is the last time I buy HRB packs.
    Alot of people on here run SMC's and speak highly of them, I personally run Gensace and have never had a bad battery in the last 2 yrs or had a cell go dead on me, they always balance out on charging.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •