Results 1 to 7 of 7
  1. #1
    RC Racer
    Join Date
    Sep 2017
    Posts
    119

    Surging under heavy acceleration

    I have just regeared to 35/55 and it's insane on 3s, I'm running a 120a esc and motor but under heavy acceleration she surges, like going through gears, start, 1,2,3 lunacy speed. I was thinking about a cap pack to level it out, any ideas? It didn't do it on stoxk gearing, or 27/62.

    Sent from my POT-LX1 using Tapatalk

  2. #2
    RC Racer
    Join Date
    Sep 2017
    Posts
    119
    I lowered the punch settings on the esc and this seems to have cured a lot of it.

    Sent from my POT-LX1 using Tapatalk

  3. #3
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,271
    It does sound like a power delivery issue. Possibly weak battery for the amps required for the higher gearing. Do you have another battery to try?

  4. #4
    RC Racer
    Join Date
    Sep 2017
    Posts
    119
    I do but only the same brand, i use these batteries in several other rcs and don't have this problem. I'm going to swap out the esc tomorrow for a castle sidewinder i have in my merv.

    Sent from my POT-LX1 using Tapatalk

  5. #5
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,271
    I had a similar issue when I got my E-revo 2.0. I had a set of batteries that I used in my brushless summit. It has a T8 2000kv truggy motor with the RX8 ESC. The batteries worked fine even with the truck being heavier and with bigger tires. When I tried them in the Erevo it accelerated like a slug. I bought a new set of batteries and it takes off like a rocket. The batteries are still good, they just can't keep up with extra amps needed with a more aggressive setup.

  6. #6
    RC Racer
    Join Date
    Sep 2017
    Posts
    119
    Hi guys, it seems like it was the esc, i put an old castle sidewinder in her and she ran like a champ, smooth, fast, precise.

    Ultimately i guess you get what you pay for, i won't cheap out on hobbywing or hobby king rubbish again, it's traxxas or castle escs from now on.


    Thanks guys for your help.

    Sent from my POT-LX1 using Tapatalk

  7. #7
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,271
    Quote Originally Posted by MikeyRC View Post
    Hi guys, it seems like it was the esc, i put an old castle sidewinder in her and she ran like a champ, smooth, fast, precise.

    Ultimately i guess you get what you pay for, i won't cheap out on hobbywing or hobby king rubbish again, it's traxxas or castle escs from now on.
    That's a bummer! Glad you got it figured out though.

    That's what I do for ESC's (and servos). I keep to what i've had good luck with (Traxxas,Castle,Tekin), even if they are a couple bucks more. I believe in "you get what you pay for."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •