Results 1 to 6 of 6
  1. #1
    RC Enthusiast
    Join Date
    Apr 2020
    Posts
    44

    How did this happen?

    Hey guys so I was doing speed runs with my e revo and got 72 mph. Then when I was going about 65mph the wheel flies off. After what seemed like many painful cartwheels I inspect the car. The wheel but seemed to be on the thread still. After a long walk I find the wheel check it out:



    Has this happened to anyone else?


    Sent from my iPhone using Tapatalk

  2. #2
    RC Champion Acidic01's Avatar
    Join Date
    Jul 2018
    Location
    beaverton oregon
    Posts
    1,481
    Never see that before.

    Does it look melted at all in the hub area? I can't tell from pic.

    Reason I ask. If it looks melted. Check your wheel bearings. They may be going out. Introducing heat which makes the plastic soft. And then wheel pulls out.

    I've had bad bearings heat up enough to melt the housing they where in. ( Diff housing for rustler. )

    Sent from my Pixel 3 XL using Tapatalk

  3. #3
    RC Champion RICK DIZZLE's Avatar
    Join Date
    May 2008
    Location
    Sierra Vista, AZ
    Posts
    1,395
    I'm leaning towards bad wheel bearings as well causing drag, thus heat and then softening the wheel to failure.

  4. #4
    RC Enthusiast
    Join Date
    Apr 2020
    Posts
    44

    How did this happen?

    The wheel hub was really hot I actually burnt my hand touching it. But the bearings are as smooth as butter I replaced them lat week. It is not melted in the hub area it just looks stripped.


    Sent from my iPhone using Tapatalk

  5. #5
    RC Champion RICK DIZZLE's Avatar
    Join Date
    May 2008
    Location
    Sierra Vista, AZ
    Posts
    1,395
    Something is causing the heat. I run my street ERevo 2.0 on GRP 1/5th street wheels and EMperformance adapters..run a ton of speed runs at high speeds, my hubs get warm but never hot.

  6. #6
    RC Turnbuckle Jr. olds97_lss's Avatar
    Join Date
    Dec 2003
    Location
    Dekalb, IL
    Posts
    3,265
    I've had it happen, but not with traxxas wheels. I bought some thunder tiger MT4 wheels/tires for my ERBEv2 early on. They were light, gripped decent on grass without being overly grabby, taller sidewalls to add more cushion on landings and had a lot of contact area for lasting a long time at the skate park.

    The MT4 has keyed hubs, but they are just different enough to not work on traxxas hubs. I cut the notches in the wheels just enough to fit. Seemed all good for a while, then as I was approaching a jump, one of my tires came off and went rolling right on by. Took the entire center part out where the hex goes.

    Anyway, yours looks like it may be heat related. Or the nut was loose and it wobbled itself to death and flew off.
    https://www.youtube.com/c/olds97lss

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •