Results 1 to 9 of 9
  1. #1
    RC Qualifier Rico116's Avatar
    Join Date
    May 2020
    Location
    South Florida
    Posts
    250

    Accessories not working

    How's everyone doing?
    My first run after getting a replacement esc from Traxxas the truck is fixed now.
    But before the replacement esc I had two yeah racing fans and the heatsink at first starting up the truck both were spinning and after a little bit one would stop. Learned to live with it as its only one. Added some headlights and tail lights the day before I sent my esc in along with the 2 fans connected fans were working and lights were working.
    Sent esc in.

    I now have the new esc fans work, lights work however it works upon turning it on after running it for a little bit lights stay on both fans shut off and truck still runs fine.

    What could this be? I been looking at stuff like battery receiver packs would that be a good option to run my accessories off of ?
    What are other options?
    Any help would be greatly appreciated, thanks

    Sent from my SM-A716U using Tapatalk

  2. #2
    RC Champion RICK DIZZLE's Avatar
    Join Date
    May 2008
    Location
    Sierra Vista, AZ
    Posts
    1,395
    I run both my fans off a 2s receiver lipo on all my E Revo's. I mount the 2s lipo to my chassis brace. Never had an issue.

  3. #3
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,115
    How do you have your fans and lights hooked up? I have my Yeah racing fans hooked up to my receiver.

  4. #4
    RC Qualifier Rico116's Avatar
    Join Date
    May 2020
    Location
    South Florida
    Posts
    250
    Quote Originally Posted by RICK DIZZLE View Post
    I run both my fans off a 2s receiver lipo on all my E Revo's. I mount the 2s lipo to my chassis brace. Never had an issue.
    Thanks, may be a good option

    Sent from my SM-A716U using Tapatalk

  5. #5
    RC Qualifier Rico116's Avatar
    Join Date
    May 2020
    Location
    South Florida
    Posts
    250
    Quote Originally Posted by grizzly03 View Post
    How do you have your fans and lights hooked up? I have my Yeah racing fans hooked up to my receiver.
    Thanks, I have it hooked up to my receiver as well.

    Sent from my SM-A716U using Tapatalk

  6. #6
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,115
    They shouldn't shut off because of the ESC. The ESC supplies power to the receiver. If it was the ESC causing the issue everything connected to it should have problems (steering servo). Possible brown outs or lost signal.

    How are your lights hooked up?

    I'm thinking you could have a bad connection or the fans could be bad.

  7. #7
    RC Qualifier Rico116's Avatar
    Join Date
    May 2020
    Location
    South Florida
    Posts
    250
    Everything is connected to the receiver the lights all 5 channels are full. I just don't understand the plastic fans never gave me issues till I upgraded to aluminum yr fans. I'm thinking it might be a reciever issue if that could even be a thing. And the aluminum fans get really hot - warm.
    And if I spin the fans by hand after they stopped spinning the spin that I just hit with it it spins for like 2 seconds then dies.
    I am open to different ideas as long as I get these fans working

    Sent from my SM-A716U using Tapatalk

  8. #8
    RC Champion Acidic01's Avatar
    Join Date
    Jul 2018
    Location
    beaverton oregon
    Posts
    1,482
    I don't think the fans themselves should be getting hot. But I don't have 5hose fans not have I felt the ones I have to see if they get warm or hot.

    If there was a manufacturing issue or a short with them it could get shown as as being hot. More so if getting power and then not spinning.



    Sent from my Pixel 3 XL using Tapatalk

  9. #9
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,115
    I'm still using the plastic fans that came with the Yeah Racing heat sink kit.

    If the outside case of the aluminum fans are getting warm same as the motor that's going to be normal as they are acting as a heat sink along with the aluminum they are screwed to. If the center of the fan is getting hot that's not good, especially if the fan blows toward the motor.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •