Results 1 to 6 of 6
  1. #1
    RC poster
    Join Date
    Aug 2020
    Posts
    19

    Stampede 2wd brakes

    I have a 2wd stampede brushed 12t motor. The brakes Do not work well at low speed (slowly comes to a stop). At higher speeds itís a little bit better but not stopping instantly like vxl models. Does anyone know a fix for this.

  2. #2
    RC Qualifier
    Join Date
    Mar 2017
    Posts
    467
    Quote Originally Posted by Slashn4x4 View Post
    I have a 2wd stampede brushed 12t motor. The brakes Do not work well at low speed (slowly comes to a stop). At higher speeds it’s a little bit better but not stopping instantly like vxl models. Does anyone know a fix for this.
    Braking is done by the esc reversing current through the motor.
    The more powerful the esc and motor(vxl), the more powerful the braking...
    Last edited by fortunespoonz; 09-18-2020 at 09:25 AM.

  3. #3
    RC Enthusiast
    Join Date
    Aug 2019
    Posts
    31
    My Pede is the same way. I have the 12T. If you want immediate/hard braking, bump the trigger twice in the reverse motion. the first bump will tell the ESC to reverse the current to the motor and the second bump will slide the tires or they'll spin in reverse (depending on how much juice you give it, of course).

  4. #4
    RC Qualifier RCWilly's Avatar
    Join Date
    Feb 2019
    Location
    California Bay Area
    Posts
    666
    That's the problem with the XL-5 and Titan 12t. It's not the strongest or the most powerful motor.
    Everyday's a gift, thus now is called the present.

  5. #5
    RC Qualifier Calebs0615's Avatar
    Join Date
    May 2020
    Location
    Maine
    Posts
    687
    I noticed if your kind of slow on the brake it doesnt work well. Like if you pull back gradually.

    I find that if you jerk the trigger back towards you or whatever way you have reverse oriented, itll lock the tires up and youll get the brakes ypur looking for i think.

    Sent from my LGL722DL using Tapatalk

  6. #6
    RC Qualifier
    Join Date
    Mar 2017
    Posts
    467
    Quote Originally Posted by Slashn4x4 View Post
    I have a 2wd stampede brushed 12t motor. The brakes Do not work well at low speed (slowly comes to a stop). At higher speeds itís a little bit better but not stopping instantly like vxl models. Does anyone know a fix for this.
    Thought of something else...

    When in doubt, recalibrate the throttle.
    When doing it, push and pull the trigger smoothly and make sure you go all the way to the stop.
    Does your radio have a 70/30 throttle setting?
    If at 70/30, going back to 50/50 should help. Recalibrate after doing so.
    Whatever the case, when in doubt, recalibrate...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •