Results 1 to 6 of 6
  1. #1
    RC Qualifier
    Join Date
    Nov 2011
    Location
    New Jersey
    Posts
    257

    Lost Steering With TSM On

    I have an E-Revo Brushless v1 and have a strange problem. The truck was running great all summer and suddenly lost steering when driving. The steering works when standing still! There are no Blinking Lights on the Transmitter or Receiver. The latest firmware was installed during the summer using Link. I reset the Transmitter but nothing changed. Then I accidentally turned the TSM button on the Transmitter and the problem went away! I contacted Traxxas Suppoert but they are at a loss. Help

  2. #2
    RC Enthusiast
    Join Date
    Aug 2020
    Posts
    44
    Quote Originally Posted by 06redssr View Post
    I have an E-Revo Brushless v1 and have a strange problem. The truck was running great all summer and suddenly lost steering when driving. The steering works when standing still! There are no Blinking Lights on the Transmitter or Receiver. The latest firmware was installed during the summer using Link. I reset the Transmitter but nothing changed. Then I accidentally turned the TSM button on the Transmitter and the problem went away! I contacted Traxxas Suppoert but they are at a loss. Help
    Tsm usually lessens the steering for me.

    Domineazy

  3. #3
    RC Enthusiast
    Join Date
    Sep 2020
    Posts
    23
    For me, with tsm at 1-10%, my steering doesn't work at all. Completely off or at a higher rate and it works as advertised. Traxxas rep told me that he never heard of that and tsm doesn't work that way. But it happens to people on youtube, so I'm not the only one. It also happens on my trx6.

  4. #4
    RC Champion Acidic01's Avatar
    Join Date
    Jul 2018
    Location
    beaverton oregon
    Posts
    1,484
    I randomly get same issue. If stopped have steering. If reverse have steering. But move forward and no steering.

    Once I turn tsm off car works fine.



    Sent from my Pixel 3 XL using Tapatalk

  5. #5
    RC Champion RICK DIZZLE's Avatar
    Join Date
    May 2008
    Location
    Sierra Vista, AZ
    Posts
    1,395
    Same boat here. My street truck was fine..now after most recent updates TSM is making my steering super slow with my aftermarket servo. I have to mess with it and find a sweet spot to work correctly.

  6. #6
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,115
    I hope these updates start to get tested before being released. Or at least start to offer support with Traxxas Link and updates. It's frustrating when you know what the problem is and the only thing your able to do is wait for the update fix.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •