Results 1 to 17 of 17
  1. #1
    RC Qualifier
    Join Date
    Nov 2011
    Location
    New Jersey
    Posts
    259

    Lost Steering With TSM On

    I have an E-Revo Brushless v1 and have a strange problem. The truck was running great all summer and suddenly lost steering when driving. The steering works when standing still! There are no Blinking Lights on the Transmitter or Receiver. The latest firmware was installed during the summer using Link. I reset the Transmitter but nothing changed. Then I accidentally turned the TSM button on the Transmitter and the problem went away! I contacted Traxxas Suppoert but they are at a loss. Help

  2. #2
    RC Competitor
    Join Date
    Aug 2020
    Posts
    57
    Quote Originally Posted by 06redssr View Post
    I have an E-Revo Brushless v1 and have a strange problem. The truck was running great all summer and suddenly lost steering when driving. The steering works when standing still! There are no Blinking Lights on the Transmitter or Receiver. The latest firmware was installed during the summer using Link. I reset the Transmitter but nothing changed. Then I accidentally turned the TSM button on the Transmitter and the problem went away! I contacted Traxxas Suppoert but they are at a loss. Help
    Tsm usually lessens the steering for me.

    Domineazy

  3. #3
    RC Enthusiast
    Join Date
    Sep 2020
    Posts
    37
    For me, with tsm at 1-10%, my steering doesn't work at all. Completely off or at a higher rate and it works as advertised. Traxxas rep told me that he never heard of that and tsm doesn't work that way. But it happens to people on youtube, so I'm not the only one. It also happens on my trx6.

  4. #4
    RC Champion Acidic01's Avatar
    Join Date
    Jul 2018
    Location
    beaverton oregon
    Posts
    1,800
    I randomly get same issue. If stopped have steering. If reverse have steering. But move forward and no steering.

    Once I turn tsm off car works fine.



    Sent from my Pixel 3 XL using Tapatalk

  5. #5
    RC Champion RICK DIZZLE's Avatar
    Join Date
    May 2008
    Location
    Sierra Vista, AZ
    Posts
    1,417
    Same boat here. My street truck was fine..now after most recent updates TSM is making my steering super slow with my aftermarket servo. I have to mess with it and find a sweet spot to work correctly.

  6. #6
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,474
    I hope these updates start to get tested before being released. Or at least start to offer support with Traxxas Link and updates. It's frustrating when you know what the problem is and the only thing your able to do is wait for the update fix.

  7. #7
    RC Enthusiast
    Join Date
    Sep 2020
    Posts
    37
    My TSM doesn't work when it's set too low. ROFL. So I dumped it and run a FlySky GT5 radio. Works a lot better. https://youtu.be/adbp0hvRL9E

  8. #8
    RC Competitor
    Join Date
    Oct 2018
    Location
    Texas, by God!
    Posts
    96
    If you have no steering under throttle, you've got a bad TSM module in your receiver. Time for a new receiver. Call the guys at the Mighty TRX, and send it in. It's a LOT cheaper that way.
    I find your lack of teepee disturbing.

  9. #9
    RC Qualifier ElectricPropils's Avatar
    Join Date
    Oct 2020
    Location
    Dallas TX
    Posts
    403
    Quote Originally Posted by 06redssr View Post
    I have an E-Revo Brushless v1 and have a strange problem. The truck was running great all summer and suddenly lost steering when driving. The steering works when standing still! There are no Blinking Lights on the Transmitter or Receiver. The latest firmware was installed during the summer using Link. I reset the Transmitter but nothing changed. Then I accidentally turned the TSM button on the Transmitter and the problem went away! I contacted Traxxas Suppoert but they are at a loss. Help
    I had the same problem recently, it only happens when the TSM is set to a value roughly below 25% so it's not really a problem for most people. It goes away if you put TSM to 0%.
    The present is theirs; the future, is mine.

  10. #10
    RC Qualifier ElectricPropils's Avatar
    Join Date
    Oct 2020
    Location
    Dallas TX
    Posts
    403
    Quote Originally Posted by TheFirestarter View Post
    For me, with tsm at 1-10%, my steering doesn't work at all. Completely off or at a higher rate and it works as advertised. Traxxas rep told me that he never heard of that and tsm doesn't work that way. But it happens to people on youtube, so I'm not the only one. It also happens on my trx6.
    It's not a problem when you turn it off or above around 25%
    The present is theirs; the future, is mine.

  11. #11
    RC Competitor
    Join Date
    Aug 2020
    Posts
    57
    Quote Originally Posted by Darth Beavis View Post
    If you have no steering under throttle, you've got a bad TSM module in your receiver. Time for a new receiver. Call the guys at the Mighty TRX, and send it in. It's a LOT cheaper that way.
    Is the TSM module the gyro inside?

    Domineazy

  12. #12
    RC Qualifier ElectricPropils's Avatar
    Join Date
    Oct 2020
    Location
    Dallas TX
    Posts
    403
    Quote Originally Posted by Domineazy View Post
    Is the TSM module the gyro inside?

    Domineazy
    Yes, but I wouldn't bother replacing it if your car works without TSM or with a TSM setting higher than 30%. There is a common problem in which having your TSM set 1% to roughly 25% keeps the wheels from turning under throttle (they will either not turn at all or they will fidget around).
    The present is theirs; the future, is mine.

  13. #13
    RC Competitor
    Join Date
    Aug 2020
    Posts
    57
    Quote Originally Posted by ElectricPropils View Post
    Yes, but I wouldn't bother replacing it if your car works without TSM or with a TSM setting higher than 30%. There is a common problem in which having your TSM set 1% to roughly 25% keeps the wheels from turning under throttle (they will either not turn at all or they will fidget around).
    Yeah but it is able to partially turn to the right and somehow all the way to the left. I messed with the tsm but that was the end result because before that it would turn at a standstill and once throttle was applied it would snap back to straight and wouldn't turn while in motion. It's never done this before until recently.

    Domineazy

  14. #14
    RC Racer SpeedieGonzales's Avatar
    Join Date
    Jun 2019
    Location
    Sanford, Fl
    Posts
    148
    Traxxas Slash 4x4 (no TRX link) and similar problem... but it's much more random. It can occur anywhere between 25% TSM to 75, at off/max TSM It works great, but after just a few minutes of running at around 50% TSM, The steering servo seems to get weak. Once it won't even move the car if I held it from a front wheel. (Horizontally, not vertically ofc.) And the problem does not go away if I turn TSM Off. I've had it for a year and a half, 0 other steering issues aside from that (no servo breaks, no linkage breaks, only one recent A-arm break. Haven't tried resetting (yanking the battery) so next time this occurs I'll try that. LHS said servo dead, probably water, but it hasn't happened since I stopped using TSM because I like drifting and TSM tries to keep it from doing so, so the car doesn't do what I expect.

    Also, I like how as a kid, I wanted a "Drift box" (Don't ask where I heard it from) for my toy-grades but now I don't need it, And I actually use the opposite XD

    Florida Man cares not from whence the speed comes, only that it does.
    Last edited by SpeedieGonzales; 11-05-2020 at 08:58 AM.

  15. #15
    RC Enthusiast
    Join Date
    Sep 2020
    Posts
    37
    nope, my trx6 and erevo 2.0 both have the issue I linked in the video... from 1% to 25% it doesn't allow for steering. This is a huge flaw.

  16. #16
    RC Competitor
    Join Date
    Aug 2020
    Posts
    57
    Quote Originally Posted by TheFirestarter View Post
    nope, my trx6 and erevo 2.0 both have the issue I linked in the video... from 1% to 25% it doesn't allow for steering. This is a huge flaw.
    Can't watch the vid right now it's not loading. But you're telling me that if I change the tx/rx all problems solved?

    Domineazy

  17. #17
    RC Enthusiast
    Join Date
    Sep 2020
    Posts
    37
    Quote Originally Posted by Domineazy View Post
    Can't watch the vid right now it's not loading. But you're telling me that if I change the tx/rx all problems solved?

    Domineazy
    What I'm saying is I have the issue on both my traxxas vehicles and both radios. I use an aftermarket rx tx (fs gt5) and use it's tunable gyro which is far beyond what traxxas has. swapping in a new receiver won't change anything as this is a widespread issue. Traxxas needs to update the firmware or something.

    If you want to use the tqi system you need to keep the intervention high. I'd keep it at 50% or 0%.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •