Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Sep 2020
    Posts
    3

    2.0 bought on 9/22 broken 9/24. Didnít even bash it :(

    Something in the drivetrain let loose and now the truck makes a nasty noise. When you try to roll it there is more nasty noises. Terrible! I donít even have 2 hours on it! I donít even bash just a hard driver.

  2. #2
    RC Champion RICK DIZZLE's Avatar
    Join Date
    May 2008
    Location
    Sierra Vista, AZ
    Posts
    1,397
    Did you happen to use the dreaded self-right feature? Open the pinion/spur cover and see if the motor worked itself a tad loose and maybe you ate a gear there. Hopefully easy and we can get you up and running.

  3. #3
    RC Enthusiast
    Join Date
    Sep 2020
    Posts
    33
    What kind of noise? can you post a video or link to one? Take the plastic motor cover off, remove the stainless bolt and plastic mesh device from the blue motor plate and rotate the motor away from the spur gear. Roll the truck back and forth to see if its smooth or makes noises. Also, put the truck on a stand so no wheels touch anything, I use a homedepot bucket, and spin the spur gear with your finger to see if the drivetrain isn't smooth.

    Quote Originally Posted by ToyotaTyler View Post
    Something in the drivetrain let loose and now the truck makes a nasty noise. When you try to roll it there is more nasty noises. Terrible! I don’t even have 2 hours on it! I don’t even bash just a hard driver.

  4. #4
    RC Racer
    Join Date
    Jun 2020
    Posts
    115
    I bet the spur gear went. Same thing happened to mine within the week of me owning it. I've also needed a drive shaft after I sheered mine.

    Take the cover off and see if the spur gear has any teeth left.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •