Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Sep 2020
    Posts
    1

    Steering works, throttle no

    Hello, I've a problem with a Teton. Steering works but throttle doesn't. When I push throttle the led on the receiver blink green. Recalibate the throttle and rebind tx and rx doesn't solve.
    Motor Is ok because connected directly to battery It works.

    Ant suggestion?

    Thanks
    Mario

  2. #2
    RC Enthusiast
    Join Date
    Apr 2021
    Location
    lakewood washington
    Posts
    20
    have you tried putting a new esc in it? I had the same problem, and some times if I held down the throttle, and gave it a lil kick, it would go, and just drop it to the ground sometimes worked for me?

  3. #3
    RC Enthusiast
    Join Date
    Jan 2018
    Posts
    33
    Quote Originally Posted by manburg6 View Post
    Hello, I've a problem with a Teton. Steering works but throttle doesn't. When I push throttle the led on the receiver blink green. Recalibate the throttle and rebind tx and rx doesn't solve.
    Motor Is ok because connected directly to battery It works.

    Ant suggestion?

    Thanks
    Mario
    Same thing happened to me. My son's Teton had no throttle and just steering. I bound my transmitter from my prerunner to the teton and everything worked. I then bound the original transmitter back to the teton and then everything worked. So I have no idea why I had no throttle. When I had original issue I did notice when I pulled throttle the ESC light would change so I knew it was getting some kind of input but it just wouldn't move. If you have another traxxas rig try that transmitter

  4. #4
    RC Enthusiast
    Join Date
    Apr 2021
    Location
    lakewood washington
    Posts
    20
    Quote Originally Posted by Cambam71 View Post
    Same thing happened to me. My son's Teton had no throttle and just steering. I bound my transmitter from my prerunner to the teton and everything worked. I then bound the original transmitter back to the teton and then everything worked. So I have no idea why I had no throttle. When I had original issue I did notice when I pulled throttle the ESC light would change so I knew it was getting some kind of input but it just wouldn't move. If you have another traxxas rig try that transmitter
    yes, I have heard it is a binding issue on almost all rc cars

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •