Results 1 to 7 of 7
  1. #1
    RC poster
    Join Date
    Oct 2020
    Posts
    3

    Unhappy Transmitter 6528 & Receiver 6533 servo end point adjustment (EPA) problems

    Hello friends!

    After 8 years I decided to install a new receiver with TSM to my Slash.
    I bought a new receiver #6533 and 2-channel transmiter #6528.
    There was no problems with binding.
    All looks great until..... I tried to set EPA in my new transmitter but after when I switched it off, a new settings just gone.

    I tried many times but without result.
    Here is a video:

    https://youtu.be/DuqOHll1fss

    Any ideas to fix this?
    Thank you!

  2. #2
    RC Champion
    Join Date
    Feb 2020
    Location
    Canary Islands, Tenerife, Spain.
    Posts
    1,379
    ┐Are you sure you do all the settings steps?

    See pages 15, 16 and 17.

    https://traxxas.com/sites/default/fi...0EN-FR_WEB.pdf
    Last edited by Juanmacine; 10-16-2020 at 02:48 PM.

  3. #3
    RC poster
    Join Date
    Oct 2020
    Posts
    3
    Thank you for your answer, but before I did all the steps shown in the video, I also unlocked all possible models saved in the radio's memory. So it dosn't work...

    Anyone had this problem? :/

  4. #4
    RC Champion
    Join Date
    Feb 2020
    Location
    Canary Islands, Tenerife, Spain.
    Posts
    1,379
    Quote Originally Posted by myRCtime View Post
    Thank you for your answer, but before I did all the steps shown in the video, I also unlocked all possible models saved in the radio's memory. So it dosn't work...

    Anyone had this problem? :/
    Maybe you have an issue with your receiver unit, try to contact with Traxxas Online Support, thy are reliable.

  5. #5
    RC poster
    Join Date
    Oct 2020
    Posts
    3
    I think the receiver is ok, because:
    1) it was in the original package,
    2) when I turn it off and on again, all works great. But when I turn off and on again the transmiter, all settings just gone every time.
    Thank you, I will check out how Traxxas support works.

  6. #6
    RC Champion
    Join Date
    Feb 2020
    Location
    Canary Islands, Tenerife, Spain.
    Posts
    1,379
    Quote Originally Posted by myRCtime View Post
    I think the receiver is ok, because:
    1) it was in the original package,
    2) when I turn it off and on again, all works great. But when I turn off and on again the transmiter, all settings just gone every time.
    Thank you, I will check out how Traxxas support works.
    ┐Finally you did contact Traxxas Support?

  7. #7
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,270
    Do you happen to have the Traxxas Link module?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •