Results 1 to 9 of 9
  1. #1
    RC Enthusiast
    Join Date
    May 2020
    Posts
    20

    Transmitters linking to other cars

    I have a slash 4x4 ultimate and my wife has a rustler 4x4 vxl and twice now her transmitter has been linked to my slash when we power them on to use them. How do you stop this from happening. Itís pretty annoying to have to re-link them all the time.

  2. #2
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,261
    Are you turning the controllers and vehicles on one at a time? If you do, the transmitter will stay linked with that vehicle.

  3. #3
    Marshal Double G's Avatar
    Join Date
    May 2008
    Posts
    14,226
    What a mess that would create if a bunch of Traxxas owners got together to bash and each transmitter randomly linked to someone else's vehicle. They shouldn't be linking to each other unless they have been previously done so. Straight from the factory the tx and rx are linked and they know of no others unless introduced to each other.

    I would take the recommendation of my friend above - turn one transmitter and receiver on at a time. Or erase the memories of each and relink the Slash to Slash and Rustler to Rustler.
    The Super Derecho

  4. #4
    RC Enthusiast
    Join Date
    May 2020
    Posts
    20
    It has happened twice now and we had to re link each to each. I was putting my body on on the counter the other day and she was in the other room and all of a sudden mine holeshot off the counter when my transmitter was next to me

  5. #5
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,261
    I would do a factory reset on the transmitters and re-bind the transmitters to only the one you want and that should fix it. Double G is right that they shouldn't connect unless someone went through the process of binding them.

    Traxxas radio reset video: https://www.youtube.com/watch?v=B-qcJUVCc5o

  6. #6
    RC Enthusiast
    Join Date
    May 2020
    Posts
    20
    I went through that entire process with both of them and re bonded them and it still did it again on their own. Super weird.

  7. #7
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,261
    That is very strange. Are you using or have the Blue Tooth module?

  8. #8
    RC Enthusiast
    Join Date
    May 2020
    Posts
    20
    I have the Bluetooth transmitter but Iím not using it

  9. #9
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,261
    Sorry it took a bit to get back to you. Reason I was asking is that can over-ride the transmitter when turned on. It has it's own memory. It would be a good idea also to delete the saved vehicles on the Traxxas Link app.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •