Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Oct 2020
    Posts
    1

    Brand new XMaxx issues!!!!!

    Just opened up a brand new xmaxx 8s..... Charged two new 4s lipo batteries, installed in truck and have a truck that is completely whacked. Steering will work, have no forward or reverse (other then a random twitch of throttle in the wrong direction) steering starts wondering all over the place on its own. When I hit the throttle the green light goes out for a split second on the esc then comes back on. Does this every time in forward or reverse. Been out of RC for a while, all of this crazy electric stuff has me Puzzled. Any help would be appreciated! 🍻

  2. #2
    RC Champion Acidic01's Avatar
    Join Date
    Jul 2018
    Location
    beaverton oregon
    Posts
    1,531
    https://youtu.be/ix-J85uRFjE

    Try this.

    Make sure batteries in transmitter is good as well.

    Sent from my Pixel 3 XL using Tapatalk

  3. #3
    RC Racer Nickerz's Avatar
    Join Date
    Jan 2016
    Posts
    231
    Also maybe try calibrating the radio and/or ESC. Otherwise, call Traxxas tech support @ 1-888-Traxxas which is one of the best in the business imo...

  4. #4
    RC Turnbuckle Jr. ReglarGuy's Avatar
    Join Date
    Feb 2012
    Location
    Eastern Shore, Maryland
    Posts
    4,579
    If you bought your Xmaxx online, call Traxxas Customer Support. They will be very helpful for you. If you got your Xmaxx from a hobby store, go back and let those guys help you out. In the future, for a little while anyway (if possible), you should get all your RC stuff from a hobby store. Yes, you'll probably pay a few bucks more for all your stuff, but when you're new to RC (or, been out of it for a while as you have) the extra buck (or two) you spend will be returned to you "10 fold" in free help and advice. Then when you get your RC footing or (in your case) your RC footing back, you can shoot for the best deals "on" or "offline."
    Last edited by ReglarGuy; 10-29-2020 at 02:47 AM.
    Life's to short to be a sour puss.

  5. #5
    RC Champion
    Join Date
    Feb 2020
    Location
    Canary Islands, Tenerife, Spain.
    Posts
    1,350
    Quote Originally Posted by Otcinc View Post
    Just opened up a brand new xmaxx 8s..... Charged two new 4s lipo batteries, installed in truck and have a truck that is completely whacked. Steering will work, have no forward or reverse (other then a random twitch of throttle in the wrong direction) steering starts wondering all over the place on its own. When I hit the throttle the green light goes out for a split second on the esc then comes back on. Does this every time in forward or reverse. Been out of RC for a while, all of this crazy electric stuff has me Puzzled. Any help would be appreciated! ��
    Hi mate, welcome to the Traxxas Forums, as mates says, try the procedures to reset this ESC and calibrate the RX/TX systems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •