Results 1 to 22 of 22
  1. #1
    RC Racer
    Join Date
    Aug 2020
    Posts
    215

    Think ESC is dead, any advice please?

    I've not used the MERV for a few weeks, so gave it a run today.
    Last few times I've run it, I thought there was an issue with it overheating, as it would shut off the throttle after a while. Today it just seems to have died. I was having a jumping session, so don't think that heat was an issue, running gently in that respect.
    The car is dead, with just a faint glimmer of red on the led on the ESC.
    Just to be safe I tried another battery, same result. Same an hour later.
    Any suggestions or is it time for a replacement?

    Oh yeah, it did seem a little jumpy at very low speeds, but that might not be new, don't normally go slow. Lol

  2. #2
    RC Champion zedorda's Avatar
    Join Date
    Sep 2015
    Location
    S.E. Michigan
    Posts
    1,480
    Jumping session and running gently don't make any sense. When you force your rig to climb a ramp and launch into the air. You are asking alot of the electronics and yes causing about the same heat as running through grass. And if you are not good at speed matching the rig's wheels with the speed they need to be on landing those jumps you are causing even more heat. Since when you land the ESC is either braking or spinning the wheels. If the wheels are going too fast then more power is used. If the wheels are going to slow/stopped then power is used to brake/slow down the rig.

  3. #3
    RC Qualifier
    Join Date
    Jun 2020
    Location
    Texas
    Posts
    274
    The first thing I would confirm is that all wires are secured well, especially those around the esc and motor. In general though, it should cut out before it heats to the point that it dies (not always). I find the vxl-3m overheats kinda easy - even when the motor is no where close.

    When you say "faint glimmer of red" on the led - is it blinking?

  4. #4
    RC Racer
    Join Date
    Aug 2020
    Posts
    215
    Thanks for the replies guys.

    Reason I said it was a gentle session, there was a lot of down time and I wasn't gunning it jump the ramp from miles back. Motor temp was only just over 100. I can't monitor the ESC so I guess it could have been cooking without me realising. It wasn't hot to touch though.

    I plugged a battery in this morning, constant flashing red led, but really faint. After pressing the on button that is.

  5. #5
    RC Qualifier
    Join Date
    Jun 2020
    Location
    Texas
    Posts
    274
    Quote Originally Posted by Chewbacca 3 View Post
    Thanks for the replies guys.

    Reason I said it was a gentle session, there was a lot of down time and I wasn't gunning it jump the ramp from miles back. Motor temp was only just over 100. I can't monitor the ESC so I guess it could have been cooking without me realising. It wasn't hot to touch though.

    I plugged a battery in this morning, constant flashing red led, but really faint. After pressing the on button that is.
    Well for reference, here is the ESC manual: https://traxxas.com/sites/default/fi...207_ML_web.pdf

    Depending of the speed of the blinking it means two different things. IF it is slow, then it is low voltage detection - which typically means battery, but also could mean poor connection to power source. If it is fast blinking - that should only happen during overheating - if it is doing that while cold - not sure what it would be.

    You can also try contacting traxxas support.

  6. #6
    RC Champion Acidic01's Avatar
    Join Date
    Jul 2018
    Location
    beaverton oregon
    Posts
    1,768
    Guessing rx light is green?

    Off chance perhaps it needs throttle calibration?

    Sent from my Pixel 3 XL using Tapatalk

  7. #7
    RC Racer
    Join Date
    Aug 2020
    Posts
    215
    I'll check the rx later tonight.
    When I say the light is faint guys, its really dim, plus flashing quite quickly.

  8. #8
    RC Competitor
    Join Date
    May 2020
    Posts
    58
    Mine cuts out after 2 speed runs of about 20m. Like everything is off....
    I have to switch the ESC on and then it runs fine again. My batteries has got him wires so I think the power supply to the system is just too small and then everything switches off... anybody else had such an issue?

  9. #9
    RC Racer
    Join Date
    Aug 2020
    Posts
    215
    Quote Originally Posted by Acidic01 View Post
    Guessing rx light is green?

    Off chance perhaps it needs throttle calibration?

    Sent from my Pixel 3 XL using Tapatalk
    Unfortunately not, it's flashing red and won't link. I'm going to take it this means its not seeing the correct power from the ESC.
    I'll check my transmitter on another truck just in case, but that seems unlikely. I'll also see if I have an old receiver pack or similar kicking about to power up the receiver with the ESC disconnected
    The flashing led on the receiver is so bright compared to the ESC, it makes me think the ESC isn't well.

  10. #10
    RC Racer
    Join Date
    Aug 2020
    Posts
    215
    OK, bit of an update...
    Pinched another ESC from a stampede and plugged into my receiver. Still no working receiver.
    Powered up my ESC with nothing attached, green light.
    Pulled everything out of the receiver, barring the stampede ESC, receiver now goes green.
    Plugged original ESC back into receiver, green light on both.
    Plugged in servo, 2 red lights. Unplugged servo, 2 green lights.
    Tried the stampede servo, 2 green lights and working servo.

    Fairly conclusive its the servo is dragging 6v rail down and killing everything. It's still the stock servo from when the truck was a ken block rally, so it owes me nothing. I'll double check everything tomorrow though.

    So, I guess the next question, any suggestions for a good servo, without breaking the bank?

    Cheers for the help guys? I'd don't think I'd have checked the receiver before condemning the ESC.

  11. #11
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,431
    Quote Originally Posted by Chewbacca 3 View Post
    So, I guess the next question, any suggestions for a good servo, without breaking the bank?
    While I'm not a Savox guy, they did a good job with making one for the Traxxas's 1/16's.
    The Savox SW-0250MG is a great upgrade. And they can be had for $30US.

  12. #12
    RC Racer
    Join Date
    Aug 2020
    Posts
    215
    Thank you, I was looking at those. That makes my mind up. My favourite UK store has them in stock.

  13. #13
    RC Champion Acidic01's Avatar
    Join Date
    Jul 2018
    Location
    beaverton oregon
    Posts
    1,768
    Savox 0250mg 20 to 30$ more than enough for these little cars if run bigger tires may want a servo with more power

    Sent from my Pixel 3 XL using Tapatalk

  14. #14
    RC Qualifier
    Join Date
    Jun 2020
    Location
    Texas
    Posts
    274
    I have one of those savoxs on my Amain wishlist for the day my stock servo bites it

  15. #15
    RC Racer
    Join Date
    Aug 2020
    Posts
    215
    I took the faulty one to bits, expecting to see the plastic gears in tatters, but they are all good.
    Left them off the servo and plugged it back in. Still 2 green lights. Turned the steering control, motor starts to spin, still 2 green lights. Tried the other direction, still good. Switched from one to the other, reds lights and everything dead. Unplugged the servo, back to green.
    I guess the control board in the servo is breaking down and causing a short. I expected the motor to have seized up when the gears were intact.

    Anyways, savox ordered. Hopefully this will have been causing the ESC shut down, that I thought was a heat issue in my other thread, a few weeks ago. If not, guess I'll be dragging that back up. Lol.

  16. #16
    RC Racer
    Join Date
    Aug 2020
    Posts
    215
    Well, servo still hasn't arrived, but I've ordered a 25mm fan now for ESC and some random LEDs.
    Gonna turn into a mini rebuild session.

  17. #17
    RC Racer
    Join Date
    Aug 2020
    Posts
    215
    Hey guys, quick question...
    Will the ESC 6v rail kick out enough current for a fan as well as all the standard radio gear?
    Cheers

  18. #18
    RC Qualifier
    Join Date
    Jun 2020
    Location
    Texas
    Posts
    274
    Quote Originally Posted by Chewbacca 3 View Post
    Hey guys, quick question...
    Will the ESC 6v rail kick out enough current for a fan as well as all the standard radio gear?
    Cheers
    For me it did run one fan, but two fans it could not.

  19. #19
    RC Champion grizzly03's Avatar
    Join Date
    Dec 2014
    Location
    Adirondacks
    Posts
    2,431
    I have a 25mmx25mm yeah racing fan cooling the motor and haven't had any issues.

  20. #20
    RC Racer
    Join Date
    Aug 2020
    Posts
    215
    Great stuff. Its the yeah racing one i have coming.

  21. #21
    RC Racer
    Join Date
    Aug 2020
    Posts
    215
    Thought I'd better do a quick update...
    Finally ran a full battery through it today, no heating issues at all! Looks like the fan is a winner.
    (I'm ignoring the fact it's freezing outside lol)

  22. #22
    Traxxas Marshal
    Join Date
    Mar 2003
    Location
    Wherever the road takes me.
    Posts
    38,065
    Ignorance is bliss!

    (Just be sure to keep an eye on it when the temps start to get warmer.)

    Glad you're back in business, enjoy!
    "Happiness depends upon ourselves." -Aristotle

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •