Results 1 to 9 of 9
  1. #1
    RC Enthusiast
    Join Date
    Nov 2020
    Posts
    22

    Maxx servo drifting left when TSM is on

    Hi all. Hope you can help me with some advice. Iím new to the forum and a complete amateur on RC things. My new Maxx (a week old or so) has started to behave oddly. When TSM is on, as soon as I touch the throttle, even super gently so wheels barely turn, the steering servo moves gradually until full left lock is reached. It does the same at any level of throttle, it just drifts over. When I release the throttle the servo re-centres. If I turn TSM off, it doesnít happen. It seems to happen faster at higher settings of the TSM. If I steer when using the throttle it seems to override the servo drift, and steers seemingly normally, but as soon as I leave the steering alone it drifts left again. I can only think that the TSM is interfering with the steering control somehow.

    Any suggestions?

    I havenít driven it since Iíve noticed and I imagine itíll not be noticeable so long as Iím steering it, but itíll swerve left if Iím not making any steering inputs. Iíve turned off and on again, replaced battery, and updated firmware in the controller with the link module (I just got it). Iíve pulled the wheels off and it does the same when sat on the bench.

    Hope you can help. Thanks!

  2. #2
    RC Champion
    Join Date
    Mar 2016
    Posts
    1,402
    I never use tsm

    30 day warranty running out quickly
    Better get to testing it

    Enjoy until it breaks
    fabricator

  3. #3
    RC Enthusiast
    Join Date
    Nov 2020
    Posts
    22
    That doesn’t sound good then. I’ll speak to the shop I bought it from to see about a warranty claim. Thanks

  4. #4
    RC Enthusiast
    Join Date
    Nov 2020
    Posts
    26
    Just some obvious question - Is your steering trim set to center - if you adjust your steering trim to the right does it compensate for the left drift? If you turn the TSM off does it still do the same? - Have you checked your steering horn is secured correctly to your servo and is set in zero position?

  5. #5
    RC Enthusiast
    Join Date
    Nov 2020
    Posts
    22
    Thanks - the trim just seems to affect where it starts drifting from, and it makes no real difference where I set it. It progresses all the way to full left lock over the course of a few seconds. Turning TSM off prevents it, and the rate of drift seems to be proportional to the level of TSM. Steering horn is secure abd is where it came as bee. I haven’t checked zero position yet, but the steering recentres as soon as I release throttle so it does all seem to be as it should.

  6. #6
    RC Enthusiast
    Join Date
    Nov 2020
    Posts
    26
    That is strange - hope you get it sorted on a warranty claim - good luck

  7. #7
    RC Enthusiast
    Join Date
    Nov 2020
    Posts
    22
    So, shop is going to send me a new receiver to fit and see if that fixes it. Fingers crossed. I see over in the revo forum quite a lot of chat about TSM interfering with steering, so maybe there’s a bigger issue. I’ll let you know how it goes

  8. #8
    RC Enthusiast
    Join Date
    Nov 2020
    Posts
    22
    Just an update. The new receiver seemed to fix it, so that’s a result.

  9. #9
    RC Enthusiast
    Join Date
    Nov 2020
    Posts
    26
    Thats good news

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •