Results 1 to 3 of 3
  1. #1
    RC poster
    Join Date
    Apr 2021
    Posts
    1

    Faulty VXL-6S, flashing red, what to do?

    Greetings all,

    My sonís E Revo 2.0 has a problem. It suddenly stopped working, the VXL flashing red on all red diodes.
    I tried to check on YouTube how to resolve the problem but I only came across people with the exact same problem, no one seems to have a solution to this problem except sending it back to Traxxas?
    Here is one of the comments I read on YouTube, copied and pasted:

    I have that problem with my erevo 2.0 (esc vxl 6) when all the LEDs are red, it means that there is a programming error, or so it is written in the manual .... the problem is that it must be sent to traxxas for reprogramming and we as simple users cannot set a factory reset or something like that, especially if we use telemetry and we have the possibility to update software.

    Any advise will be much appreciated.

    Much obliged,

    Volker

  2. #2
    RC Champion
    Join Date
    Jul 2018
    Location
    beaverton oregon
    Posts
    2,010
    It is a send it into traxxas. Call customer support first though.

    Sent from my Pixel 3 XL using Tapatalk

  3. #3
    RC poster
    Join Date
    Apr 2021
    Posts
    4
    I honestly believe that the bist thing you should do is to call customer customer support my friend. It's simply the safest option.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •